ULogin Pro

Add-Ons for MFPS.
User avatar
websbk
Contributor
Contributor
Posts: 168
Joined: Fri Aug 04, 2017 5:34 pm

try to downgrade the php version to 7.1 Everything works fine for me
User avatar
Lovatto
Admin
Admin
Posts: 1755
Joined: Sun Dec 07, 2014 3:18 pm
Contact:

Ok... not likely a permissions issue - tested on both Ubuntu 20.04 LAMP stack 7.4 and Win 2019 MySQL PHP 7.4

Both have no issues creating the clan databases, using the full functions of the shop and login, but the google and Facebook sessions db's aren't getting created

Image
The thing is that these don't use Mysql databases like ULogin Pro do, these databases that Facebook and Google login uses are for temporary data only,
and they are using SQLite databases, so there's the possibility that your server doesn't have installed the extension for this.

from this image, check if there're some files under the 'databases' folder and let me know.
How to find your Invoice Number: Here
How to find your Order Number: Here
User avatar
KKHackLabs
Member
Member
Posts: 46
Joined: Thu May 07, 2020 3:34 pm

OK, my mistake, I wasn't clear that it was separate.

I installed sqlite3, rolled back to 7.1 and .. still the same

databases folder is empty

Image
User avatar
Lovatto
Admin
Admin
Posts: 1755
Joined: Sun Dec 07, 2014 3:18 pm
Contact:

If the SQLite databases can't be created then yes, the problem is with some server configuration, but instead of waste time figuring it out, you can simply use these pre-created empty databases that I attach below, uncompress, and upload these in the database folder that I mentioned before and you should be good.
SQLite-database.zip
You do not have the required permissions to view the files attached to this post.
How to find your Invoice Number: Here
How to find your Order Number: Here
User avatar
KKHackLabs
Member
Member
Posts: 46
Joined: Thu May 07, 2020 3:34 pm

Lovatto wrote: Sun Aug 01, 2021 4:30 am If the SQLite databases can't be created then yes, the problem is with some server configuration, but instead of waste time figuring it out, you can simply use these pre-created empty databases that I attach below, uncompress, and upload these in the database folder that I mentioned before and you should be good.

SQLite-database.zip
YOU ROCK!!

I love this team, thank you!
User avatar
vitekcz5
New Member
New Member
Posts: 9
Joined: Fri Aug 28, 2020 1:59 pm

Hi.
I tried update ULogin to the lastest version, v1.9.47. But, everytime I try to log in or create new account, there is an error.
Image

Code: Select all

HTTP/1.1 400 Bad Request
UnityEngine.Debug:LogError (object)
ULoginResult:PrintError () (at Assets/Addons/ULoginSystemPro/Content/Scripts/Internal/Structures/ULoginResult.cs:92)
bl_LoginPro/<LoginProcess>d__34:MoveNext () (at Assets/Addons/ULoginSystemPro/Content/Scripts/Runtime/Main/bl_LoginPro.cs:181)
UnityEngine.SetupCoroutine:InvokeMoveNext (System.Collections.IEnumerator,intptr)
bl_Common is ok, files on the server are updated..
I don't know why it's not working, because before everything worked well. Even the old game build works fine with old PHP files.
User avatar
Lovatto
Admin
Admin
Posts: 1755
Joined: Sun Dec 07, 2014 3:18 pm
Contact:

Did you update everything (client scripts, PHP scripts, and database structure?
the Bad request error for that HTTP call can only happen if the 'name' variable wasn't sent in the POST login request.

Check this:

in bl_Login.cs -> IEnumerator LoginProcess(...) -> at the very top of the function add this log:

Code: Select all

 Debug.Log($"Login username '{user}'");
test again in the editor and check what you get in the console after try login.
How to find your Invoice Number: Here
How to find your Order Number: Here
User avatar
vitekcz5
New Member
New Member
Posts: 9
Joined: Fri Aug 28, 2020 1:59 pm

Hi.
I've already fixed this issue, but now I am having another problem. I always get 401 error when trying to create account/ login.

Image

Code: Select all

Error:HTTP/1.1 401 Unauthorized
UnityEngine.Debug:Log (object)
bl_LoginPro/<RegisterProcess>d__43:MoveNext () (at Assets/Addons/ULoginSystemPro/Content/Scripts/Runtime/Main/bl_LoginPro.cs:506)
UnityEngine.SetupCoroutine:InvokeMoveNext (System.Collections.IEnumerator,intptr)
I am using Awardspace as my web hosting and it worked great until I've updated to the new ULogin version. The old game build still works.
User avatar
Lovatto
Admin
Admin
Posts: 1755
Joined: Sun Dec 07, 2014 3:18 pm
Contact:

vitekcz5 wrote: Mon Aug 16, 2021 4:19 am Hi.
I've already fixed this issue, but now I am having another problem. I always get 401 error when trying to create account/ login.
Make sure the 'SecretKey' is the same in both LoginDataBasePro -> SecretKey and bl_Common.php -> SECRET_KEY.
also, make sure you have the PeerToPeer sync (on or off) in both too, LoginDataBasePro -> PerToPerEncryption and bl_Common.php -> PER_TO_PER_ENCRYPTION
How to find your Invoice Number: Here
How to find your Order Number: Here
Post Reply