Customizer Addon Errors.

General support.
Post Reply
User avatar
pyatyorochka
Contributor
Contributor
Posts: 25
Joined: Sun Jun 13, 2021 4:55 am

Hello! After settings, i have this:
https://ibb.co/bzm6TSj
Video:
https://youtu.be/kK5Sh5KJyEE

What i have to do?
User avatar
Lovatto
Admin
Admin
Posts: 1781
Joined: Sun Dec 07, 2014 3:18 pm
Contact:

Hi,

This is caused due to the rifle mesh of MFPS and the customizer one are not the same,
you should not have this problem with your own weapons.

If you want to use the MFPS default rifle, then you can apply this fix:

in the script bl_AttachmentsPositions.cs -> add this variable:

Code: Select all

[Header("Settings")]
        public float transferSizeMultiplier = 1;
then in bl_CustomizerWeaponEditor.cs -> Transfer() -> replace these lines:

Code: Select all

clone.transform.localPosition = data[0];
            clone.transform.localEulerAngles = data[1];
            clone.transform.localScale = data[2
with these:

Code: Select all

clone.transform.localPosition = data[0] * _CustomizerWeapon.Positions.transferSizeMultiplier;
            clone.transform.localEulerAngles = data[1];
            clone.transform.localScale = data[2] * _CustomizerWeapon.Positions.transferSizeMultiplier;
Finally, in the Customizer scene, select the SMG customizer instance under: CustomizerManager -> Root -> SMG, -> bl_Customizer -> Positions -> Set the "Transfer Size Multiplier" to 0.1,
then transfer the attachments again and it should setup the attachments correctly.

Image
How to find your Invoice Number: Here
How to find your Order Number: Here
User avatar
pyatyorochka
Contributor
Contributor
Posts: 25
Joined: Sun Jun 13, 2021 4:55 am

Hello! Thanks, it helped. But there is still a problem that I showed in the video above, as well as in the video below:
https://youtu.be/sBjUwMq9ohM
The shotgun and pistol have incorrect attachments, and the pistol's magazine is also duplicated.
What i have to do?
User avatar
Lovatto
Admin
Admin
Posts: 1781
Joined: Sun Dec 07, 2014 3:18 pm
Contact:

The attachments have not been transferred correctly, which version of Customizer are you using?
Have you follow the documentation? MFPS -> Tutorials -> Customizer -> Setup Players?
Do you get any logs when transfer the attachments?
How to find your Invoice Number: Here
How to find your Order Number: Here
Post Reply