Input Manager - MFPS

Add-Ons for MFPS.
User avatar
docmartin
Contributor
Contributor
Posts: 11
Joined: Fri Jun 23, 2017 11:12 am
Contact:

Waiting Room pushing these errors

Assets\Addons\WaitingRoomPro\Scripts\bl_WaitingPlayerUIPro.cs(4,12): error CS0234: The type or namespace name 'Runtime' does not exist in the namespace 'MFPS' (are you missing an assembly reference?)

Assets\Addons\WaitingRoomPro\Scripts\bl_WaitingRoomPro.cs(8,12): error CS0234: The type or namespace name 'Runtime' does not exist in the namespace 'MFPS' (are you missing an assembly reference?)

Assets\Addons\WaitingRoomPro\Scripts\bl_WaitingRoomPro.cs(169,23): error CS0246: The type or namespace name 'bl_SingleSettingsBinding' could not be found (are you missing a using directive or an assembly reference?)

Assets\Addons\WaitingRoomPro\Scripts\bl_WaitingRoomPro.cs(169,55): error CS0246: The type or namespace name 'bl_SingleSettingsBinding' could not be found (are you missing a using directive or an assembly reference?)

Assets\Addons\WaitingRoomPro\Scripts\bl_WaitingRoomPro.cs(13,12): error CS0246: The type or namespace name 'bl_SingleSettingsBinding' could not be found (are you missing a using directive or an assembly reference?)

Assets\Addons\WaitingRoomPro\Scripts\bl_WaitingRoomPro.cs(14,12): error CS0246: The type or namespace name 'bl_SingleSettingsBinding' could not be found (are you missing a using directive or an assembly reference?)
User avatar
Lovatto
Admin
Admin
Posts: 1778
Joined: Sun Dec 07, 2014 3:18 pm
Contact:

Then you are not using MFPS 1.8,
the last version of these add-ons require MFPS 1.8, if you need the last version of these add-ons that are compatible with MFPS 1.7.5, send me your purchase order number in a PM.
How to find your Invoice Number: Here
How to find your Order Number: Here
User avatar
docmartin
Contributor
Contributor
Posts: 11
Joined: Fri Jun 23, 2017 11:12 am
Contact:

Yes, even imported it a second time.
User avatar
Lovatto
Admin
Admin
Posts: 1778
Joined: Sun Dec 07, 2014 3:18 pm
Contact:

These errors indicate only 1 thing and it's that you are not using MFPS 1.8 or you not properly imported it,
take in mind that MFPS updates can't be imported over MFPS projects with older versions, which means that you have to create a new clean Unity project -> then import MFPS.

Try it, create a new clean project, import MFPS 1.8 in clean following the get started video tutorial, and then import the addons.
How to find your Invoice Number: Here
How to find your Order Number: Here
User avatar
docmartin
Contributor
Contributor
Posts: 11
Joined: Fri Jun 23, 2017 11:12 am
Contact:

Wholly Poop dude. Your coming out with too much good stuff to have to start over everytime there's an update! I love your work, but you need to work on a way to update without a complete restart. Guess I need to make all my addon purchases before the restart?

Thanks for the help! :roll: :P
User avatar
docmartin
Contributor
Contributor
Posts: 11
Joined: Fri Jun 23, 2017 11:12 am
Contact:

Just purchased more addons and ready for rebuild, what's the highest LTS version of Unity MFPS 2.0 will work with?
User avatar
Lovatto
Admin
Admin
Posts: 1778
Joined: Sun Dec 07, 2014 3:18 pm
Contact:

The latest Unity LTS version is 2019.4, which is completely compatible with MFPS.
How to find your Invoice Number: Here
How to find your Order Number: Here
User avatar
docmartin
Contributor
Contributor
Posts: 11
Joined: Fri Jun 23, 2017 11:12 am
Contact:

Thanks!
Post Reply